Pages

Monday, 11 April 2011

restore-spsite error

Restoring a site collection from a Test box, to a POC box, I did the following:

1) In Central Admin, did a granular backup of the site collection, to a .bak file

2) In the new location, created a blank site collection

3) Ran the following powershell command:

restore-spsite -identity -path -verbose

4) And got the following error:

Restore-SPSite : The site collection could not be restored. If this problem persists, please make sure the content databases are available and have sufficient free space.
At line:1 char:15
+ restore-spsite <<<< -identity -path <.bak> -verbose -force
+ CategoryInfo : InvalidData: (Microsoft.Share...dletRestoreSite:
SPCmdletRestoreSite) [Restore-SPSite], SPException
+ FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRestoreSite

Solution

I tried an IISReset, but no joy.

So I...

1) In Central Admin -> Application Management, created  new Content Database.

2) Re-ran the powershell script, with the -databasename switch.

This then seemed to work as expected. 

3 comments:

  1. Same problem, only your solution didn't work out for me.

    In your steps above, did you create a new blank site against the new Content Database, or just created the content database and went for it?

    ReplyDelete
  2. Follow up: figured out my problem above, SQL Express 2008 (and the 4GB db limit there). Upgrading to 2008 R2 solved my problem (10 GB db limit now).

    ReplyDelete
  3. Hi, only just seen your comment :) Glad you sorted it!

    ReplyDelete